Back to overview
Resolved

Unplanned System-Wide Maintenance

Jun 3, 2026 at 5:29pm UTC  –  Jun 3, 2026 at 5:29pm UTC
Affected services
Back-end Services
Proxy Server
CDN Service

Resolved
Jun 3, 2026 at 5:29pm UTC

Maintenance ended

Created
Jun 3, 2026 at 5:29pm UTC

We are currently undergoing emergency maintenance that is affecting all services. At this time, we do not have an estimated time of resolution (ETA). Our engineering team is actively working on the issue, and we will provide another update as soon as we have more information. We sincerely apologize for the disruption.